Easy address to this page: http://bmt.ux.uis.no/

Basin Modelling Toolbox

From Tectonor's (creator of BMT):

Basin modelling aims at reconstructing the time evolution of a sedimentary basin in order to make quantitative predictions of hydrocarbons accumulations. The most important factors behind the generation of hydrocarbons in sedimentary basins are temperature and time. The temperature regime in a basin is affected by the various geological processes taking place throughout the history of the basin. These include processes related to basin geometry, such as basin formation (extensional tectonics), deposition/erosion of sediments and faulting, and physical processes related to compaction, heat flow and fluid flow. read more.

Unix account

You need a Unix account to run BMT, getting an account is easy and the account is usually created within a couple of hours. Se how to get it at UnixUserReg.

Starting BMT

BMT needs to run in a Solaris 10 environment, that means you have a extra login step to do but it's easy so don't worry. Heres an introduction on what you are going to do, step by step, below. First you login to the GNU/Linux workstation and start a Terminal. Then you log in to the Solaris system by executing the command xlogin-solaris in the Terminal window you just open. In the Solaris login window, before you log in, make sure your desktop system is the Java Desktop System, Release 3 (Options --> Session). When the Solaris desktop has loaded, start a Solaris Terminal, right click on the Solaris desktop and choose Open Terminal, and finaly in the Solaris Terminal type bmttutor, bmtnord or to start a new project just bmt (with data files inn $HOME/bmt) smile

Step by step
  1. Log in to one of the workstations in the GNU/Linux lab at E353
  2. Open a GNU/Linux terminal window
    1. Menu Applications --> System Tools --> Terminal
  3. Start a X-login window to a Solaris 10 host by executing the command xlogin-solaris in the GNU/Linux Terminal window.
  4. Click on Options and choose Java Desktop System, Release 3 in the Session menu. (The text Java Desktop System, Release 3 should appear below the user name input field.)
  5. Log in, to the Solaris system/desktop, with your user name and password
  6. Open a Solaris terminal window in the Solaris desktop by:
    1. Right click on the Solaris desktop and choose Open Terminal
    2. Or from the menu Launch --> Applications --> Utilities --> Terminal
  7. Start Basin Modelling Toolbox, execute one of these command in the Solaris Terminal window.
    1. bmttutor to start BMT with the tutorial data
    2. bmtnord to start BMT with the nord data

bmt.png bmt-nord.png
tutor data nord data

Exit BMT and loging out

In order to not lose data when quiting and logging out, its important to close all your running programs properly, this usually means closing them in the oposite order as they where started in. Also, the "x" button in the upper right corner is not the proper way to close a program, it may or may not present a "save work" choice before closing (depening on how the program is written). You should always use the quit/exit menu choice in the file menu, File --> Quit/Exit, this to make sure the program get to do all the "house keeping" it has to do before closing down.
  1. Close BMT, File --> Quit, "Yes" and "Yes" again if you want to save your work
  2. If you started BMT with the ssh jo2 ... command, jump to step 5.
  3. You don't have to close the Solaris terminal, but if you want to, execute logout, press CTRL-d or use the menu File --> Close Window
  4. Logout from the Solaris desktop, on the menu at the lower left corner, Launch --> Log Out ...., it's not nessessary to Save current setup, click OK.
    1. If you ignore this and close the Solaris desktop with the "x" button in the upper right corner, a lock-file will remain on the workstation and no one will be abel to start a new Solaris desktop until the lock file has been removed, by the system administrator.
  5. Logout from the GNU/Linux desktop, on the upper left side, System --> Log Out ...
  6. Don't turn of or reset the computer, ther may be other users using it, loged in from the network!
  7. Welcome back smile

Screen shot

How to take a screen shot (like those above) and save it to a file
  1. On the CentOS GNU/Linux menu, click Applications --> Accessories --> Take Screenshot
  2. Choose Select area to grab and click Take Screenshot
  3. Left click and draw a square to take a screen shot
  4. Give the picture a name, keep the png file type, save the file in the Desktop folder

Transfer files

To transfer files to and from you Unix-account, you could use a Secure File Transfer client like SSH connecting to server ba8.ux.uis.no, more info (in Norwegian at SSH innlogging) or if you also want to work with your files located on the Unix fileserver, use a SSHFS client.

Setting Norwegian keyboard in Solaris

No, this doesn't work... if you are having trouble typing a given character, use the GNU/Linux desktop instead.

Default keyborad layout is English, to get the expected character when pressing a button, sett Norwegian keyboard layout, it only has to be done once.
  1. Start the Input Method Preference Editor its located in Launch --> Preferences --> Desktop Preferences --> Input Methods
  2. Click on the Keyboard tab
  3. Deselect the Use autodetect (does not work in remote environment) check button
  4. Select Norwegian in the Physical keyboard Layout list
  5. Click Apply and OK
Topic attachments
I Attachment Action Size Date Who Comment
bmt-nord.pngpng bmt-nord.png manage 51.2 K 2010-10-20 - 11:58 TheodorIvesdal  
bmt.pngpng bmt.png manage 45.4 K 2010-10-20 - 10:19 TheodorIvesdal  
Topic revision: r11 - 2013-11-06, TheodorIvesdal
 

This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback